SuperOffice Online not responding
Incident Report for SuperOffice
Resolved
This incident has been resolved.
Posted May 06, 2020 - 09:14 CEST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 06, 2020 - 08:19 CEST
Investigating
We are currently investigating this issue.
Posted May 06, 2020 - 08:08 CEST
This incident affected: SuperOffice CRM Online (Login services).