Degraded performance
Incident Report for SuperOffice
Resolved
This incident has been resolved.
Posted about 1 year ago. Dec 18, 2017 - 10:23 CET
Investigating
We are currently experiencing degraded performance. We are investigating the issue.
Posted about 1 year ago. Dec 18, 2017 - 10:11 CET