We have seen no new occurrences of SuperOffice for Outlook remaining in a loading state since corrective action was taken, and feedback received from customers has been positive. Based on this, we consider this incident resolved.
If you are still experiencing this issue, please contact SuperOffice Support so we can assist you directly.
Posted Sep 04, 2026 - 16:05 CEST
Monitoring
We have identified the cause of SuperOffice for Outlook remaining in a loading state and have taken corrective action. The service has been stable for the past hour and we are continuing to monitor closely.
We will provide a further update once we are confident the issue is fully resolved, or if the situation changes.
Posted Sep 04, 2026 - 12:00 CEST
Investigating
Microsoft has confirmed that their Microsoft 365 service degradation has been resolved. However, we have continued to receive reports of SuperOffice for Outlook remaining in a loading state in Microsoft Outlook and Outlook on the web, including new reports this morning. Our investigation now points to a brief, intermittent issue on SuperOffice's own infrastructure serving the add-in, rather than the previously suspected Microsoft service degradation. The issue appears to have resolved itself for affected users, but we are continuing to investigate the exact root cause. If you are still experiencing a loading screen, closing and reopening the SuperOffice for Outlook add-in should resolve it as a temporary workaround. We will provide a further update once we have confirmed the root cause.
Posted Sep 04, 2026 - 10:03 CEST
This incident affected: SuperOffice CRM Cloud (API and Apps).