SuperOffice for Outlook Loading Issues

Incident Report for SuperOffice

Monitoring

All evidence gathered so far continues to point to an ongoing Microsoft 365 service degradation as the cause of this issue, and we have not identified any related problems within SuperOffice services. As this is not something SuperOffice can act on directly, we are monitoring Microsoft's incident status and its impact on SuperOffice for Outlook.

We will update this page with the latest information as it becomes available, or once the issue is confirmed resolved.
Posted Sep 03, 2026 - 18:20 CEST

Identified

We have investigated reports of SuperOffice for Outlook remaining in a loading state in Microsoft Outlook and Outlook on the web.

Based on our investigation and information published by Microsoft, the issue appears to be related to an ongoing Microsoft 365 service degradation affecting Outlook and related services. We have not identified any issues within SuperOffice services.

Microsoft is actively working on the incident and users may experience recovery at different times as the situation improves. For the latest updates, please refer to Microsoft's service health information.

We are monitoring the situation and will provide further updates if new information becomes available.
Posted Sep 03, 2026 - 17:41 CEST

Investigating

We are investigating an issue where SuperOffice for Outlook app may fail to load in Microsoft Outlook and Outlook on the web, causing the add-in to remain in a loading state.

Our investigation indicates that this may be related to an ongoing Microsoft 365 service degradation currently reported by Microsoft. We are actively monitoring the situation and assessing the impact on SuperOffice for Outlook users.

We will provide further updates as more information becomes available.
Posted Sep 03, 2026 - 13:09 CEST
This incident affects: SuperOffice CRM Cloud (API and Apps).