Temporary Login Issue

Incident Report for SuperOffice

Resolved

This incident has been resolved.
Posted Jan 24, 2026 - 14:56 CET

Investigating

Login via online.superoffice.com is temporarily unavailable.
Please use id.superoffice.com to login.
Posted Jan 24, 2026 - 11:33 CET
This incident affected: SuperOffice CRM Cloud (Login services).