Email delivery issues

Incident Report for SuperOffice

Resolved

Email delivery to Microsoft 365/Outlook.com recipients has returned to normal. We've confirmed no new "Server busy" (4.7.500) delivery failures for over an hour, and previously delayed emails are now being delivered successfully.

This aligns with Microsoft's mitigation of the underlying anti-spam enforcement issue (EX1467029). We consider this incident resolved. If you continue to experience delivery delays to Microsoft 365/Outlook.com addresses, please contact support.
Posted Sep 04, 2026 - 17:40 CEST

Update

Microsoft has confirmed the cause: an anti-spam detection model in Exchange Online was incorrectly enforcing throttling against a subset of legitimate senders, including SuperOffice, causing "Server busy" delays for messages sent to and from external domains.

Microsoft is rolling back the affected model and adding impacted sending IPs to an allow list as an interim mitigation. They estimate this rollout will complete within the next 30 minutes (as of their last update at 2:26 PM GMT+2), with their next update due by 4:30 PM GMT+2.

We expect email delivery to Microsoft 365/Outlook.com recipients to recover as this rolls out. No action is required on your end — delayed emails will continue to be delivered automatically. We'll update this page once we see delivery return to normal or once Microsoft confirms resolution.
Posted Sep 04, 2026 - 15:11 CEST

Update

We've identified the cause:
this is a confirmed issue on Microsoft's side affecting delivery to Microsoft 365 / Outlook.com mailboxes, tracked internally by Microsoft as incident EX1467029. We've verified it affects multiple independent SuperOffice email systems (login/confirmation codes and Service/CRM emails) in the same way, confirming the cause is on Microsoft's end, not ours.

Affected emails are delayed, not lost, and will be delivered automatically once Microsoft resolves EX1467029. No action is required on your end.
Posted Sep 04, 2026 - 13:18 CEST

Update

We are continuing to monitor the scope of this issue.
Posted Sep 04, 2026 - 13:06 CEST

Identified

We're aware of delays affecting emails sent from SuperOffice - including login confirmation codes, account activation links, password reset emails, and CRM mailings - to recipients whose email is hosted on Microsoft 365 or Outlook.com (Outlook, Hotmail, Live addresses).

This is caused by a known issue on Microsoft's side that is temporarily limiting how quickly they accept incoming mail from external senders, including us. It is affecting many senders across the internet, not just SuperOffice.

What this means for you:

Affected emails are delayed, not lost - our email provider automatically retries delivery over the following hours.
If you're waiting on a confirmation code or activation email and it hasn't arrived after a few minutes, please wait and try again shortly rather than requesting a new one repeatedly, as this does not speed up delivery.
No action is required on your end.
We are actively monitoring the situation together with our email delivery provider and will update this page once Microsoft resolves the underlying issue.
Posted Sep 04, 2026 - 13:05 CEST
This incident affected: SuperOffice CRM Cloud Mail Service (mailgun Outbound Delivery).