SuperOffice CRM

Incident Report for SuperOffice

Resolved

This incident has been resolved.
Posted Sep 15, 2026 - 15:25 CEST

Monitoring

A fix has been deployed for the issue affecting the login services and we are monitoring to confirm everything is back to normal.

If you are still experiencing issues, please contact our support team and we will help you directly.

Thank you for your patience.
Posted Sep 15, 2026 - 12:58 CEST

Investigating

We are currently investigating an issue affecting logins to SuperOffice.

Some customers may experience difficulties logging in to SuperOffice.

Our team is actively investigating and we will share an update as soon as we have more information.

We apologise for the inconvenience this may be causing.
Posted Sep 15, 2026 - 12:17 CEST
This incident affected: SuperOffice CRM Cloud (Login services).