Mail delivery issues in SuperOffice Cloud

Incident Report for SuperOffice

Resolved

This incident has been resolved.
Posted Mar 17, 2025 - 18:11 CET

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 17, 2025 - 16:05 CET

Identified

The issue has been identified and a fix is being implemented. (https://status.mailgun.com)
Posted Mar 17, 2025 - 12:59 CET

Update

Our mail provider is still investigating the ongoing issue, : (https://status.mailgun.com)
Posted Mar 17, 2025 - 11:12 CET

Investigating

We are currently experiencing mail delivery issues in our solution, we are investigating the issue
Posted Mar 17, 2025 - 10:32 CET
This incident affected: SuperOffice CRM Cloud Mail Service (mailgun Outbound Delivery, mailgun Inbound email processing).