SuperOffice CRM Cloud software update.

Scheduled for Apr 6, 22:00 - 23:00 CEST

Update

We will be undergoing scheduled maintenance during this time.
Posted Apr 03, 2025 - 14:05 CEST

Update

We will be undergoing scheduled maintenance during this time.
Posted Apr 03, 2025 - 14:02 CEST

Scheduled

We are updating the SuperOffice CRM Cloud.
This release is a scheduled maintenance release of SuperOffice 10.

Release details :
Detailed information on the release including release notes, can be found here: (see link for details)

This is the first group of two to be upgraded. Expected downtime is up to 5 minutes between 22:00 and 23:00 CEST.
The next group will be upgraded this upcoming Wednesday.
Posted Apr 06, 2025 - 22:00 CEST
This scheduled maintenance affects: SuperOffice CRM Cloud (Sales & Marketing Client, Service Client).