Network disruption
Incident Report for SuperOffice
Postmortem

Description and consequence of the incident

SuperOffice Online was hit by two different incidents on Wednesday February 7th 2024.  There was one isolated incident with the SuperId login service (id.superoffice.com), and another incident related capacity of outbound network traffic in the Visma datacenter.  The SuperId incident resulted in users struggling to log in.  This incident was identified 08:44 and lasted until about 12:00.

Indications of the incident related to capacity of outbound network traffic in the datacenter was first observed 05:50.  The bottleneck for the of the outbound network traffic was identified at 18:15.  A preliminary fix resolving the bottleneck was in place 18:45.

The Root cause

The root cause of the incident related to the Superid login service was a network degradation incident in Azure west Europe.  This aligns with Microsoft Incident Tracking ID: 6V3Z-VZZ

The root cause of the incident related to capacity of outbound network traffic was caused by an increased amount of open outbound network connections to queue services in Azure.  The increase of the amount of connections were greater than anticipated.  All outbound network traffic in SuperOffice Online pass through a proxy service, as part of the security measures.  This proxy service was not capable of handling this unexpected increase of outbound network connections.

Mitigation

The incident related to SuperId was resolved by scaling out and restarting the service in Azure 9:10. 

The incident related to capacity of outbound network traffic was resolved using several action: 1) The services were reconfigured to handle a greater number of connections.  2) The service was scaled out to handle additional load. 3) The feature in version 10.3.1 causing an unexpected number of outgoing connections where rolled back in a HotFix of the product.

Posted Feb 13, 2024 - 12:22 CET

Resolved
The recent incident has been resolved, and services are back to normal. Our team will conduct a postmortem analysis in the coming days to understand the root cause fully. We'll provide the postmortem report as soon as it's available. Thank you for your patience and support.
Posted Feb 09, 2024 - 13:48 CET
Update
We are continuing to monitor for any further issues.
Posted Feb 08, 2024 - 17:34 CET
Update
We are continuing to monitor for any further issues.
Posted Feb 08, 2024 - 09:49 CET
Monitoring
A fix has been implemented and we are monitoring the results. More information will come after the root cause has been investigated.
Posted Feb 07, 2024 - 19:32 CET
Update
We are continuing to work on a fix for this issue.
Posted Feb 07, 2024 - 14:14 CET
Update
We are continuing to work on a fix for this issue.
Posted Feb 07, 2024 - 11:37 CET
Update
We are continuing to work on a fix for this issue.
Posted Feb 07, 2024 - 09:55 CET
Identified
The issue has been identified and a fix is being implemented.
Posted Feb 07, 2024 - 08:03 CET
Investigating
We are currently investigating Network disruption that is causing intermittent availability issues with the SuperOffice CRM Cloud
Posted Feb 07, 2024 - 07:32 CET
This incident affected: SuperOffice CRM Cloud (Login services, API and Apps).