CRM Script Customer Experience Issues Identified

Incident Report for SuperOffice

Resolved

This incident has been resolved.
Posted Feb 20, 2026 - 19:39 CET

Identified

The issue has been identified and a fix is scheduled to roll out later today.
Posted Feb 20, 2026 - 12:52 CET

Investigating

We’ve identified a handful of customer‑experience issues related to CRM scripts. Investigation is in progress.
Posted Feb 20, 2026 - 12:31 CET
This incident affected: SuperOffice CRM Cloud (Service Client).