Email Delivery Issues via Mailgun

Incident Report for SuperOffice

Resolved

This incident has been resolved.
Posted Nov 13, 2025 - 19:06 CET

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Nov 13, 2025 - 17:05 CET

Investigating

We are currently investigating an issue that may prevent some emails from being delivered to inboxes via Mailgun. Our provider is aware of the problem and is working to identify the cause
Posted Nov 13, 2025 - 16:52 CET
This incident affected: SuperOffice CRM Cloud Mail Service (mailgun Inbound email processing).